فا

‫ آسیب پذیری CVE-2019-11477 در کرنل سیستم های عامل‌ Linux و BSD 

آسیب پذیری CVE-2019-11477 در کرنل سیستم های عامل‌ Linux و BSD

آسیب پذیری CVE-2019-11477 در کرنل سیستمهای عامل Linux و BSD در زیرسامانه شبکه کشف شده است. این ضعف امنیتی، ناشی از پردازش نادرست مقدار متغیر MSS و Selective ACK می باشد. آسیب پذیری بدین گونه است که مهاجم می تواند با ارسال ترتیبی خاص از بسته های شبکه (TCP) باعث کرش (panic) هسته سیستم عامل شود. ضعف امنیتی این آسیب پذیری از نوع Integer Overflow است.

برای رفع این آسیب‌پذیری، بهترین راه حل بروز رسانی کرنل سیستم عامل است.

آسیب پذیری CVE-2019-11479 نیز با استفاده از همین ضعف، برای مهاجم امکان اجرای یک حمله Resource Consumption را فراهم می سازد. بدین صورت که می توان سیستم عامل را مجبور کرد تا بسته پاسخ را به قطعات 8 بایتی بشکند. با درنظر گرفتن سربار سرایند سایر پروتکل های زیرین ( مانند IP و Ethernet ) می توان پهنای باند شبکه و همچنین ظرفیت CPU را مورد سواستفاده قرار داد.

جزییات بیشتر در منابع زیر در دسترس است:

https://www.openwall.com/lists/oss-security/2019/06/17/5

https://www.tenable.com/blog/sack-panic-linux-and-freebsd-kernels-vulnerable-to-remote-denial-of-service-vulnerabilities-cve


نظرات

بدون نظر
شما برای نظر دادن باید وارد شوید

مشخصات خبر

تاریخ ایجاد: 30 خرداد 1398

برچسب‌ها

امتیاز

امتیاز شما
تعداد امتیازها: 0