فا

‫ اخبار

آسیب پذیری سرویس دهنده dnsmasq

هفت نقص امنیتی مختلف بر روی سرویس دهنده dnsmsq به تازگی کشف و منتشر شده است. این #‫آسیب‌پذیری ها که از درجه خطر بحرانی تا متوسط دسته‌بندی شده‌اند منجر به آسیب‌پذیری‌هایی از نوع DNS cache poisoning و Buffer overflow می‌شوند. این مجموعه آسیب‌پذیری‌ها به مهاجم اجازه می‌دهد تا از راه دور کد دلخواه خود را بر روی سیستم اجرا کرده، حملات محروم سازی از سرویس را پیاده کرده و یا کاربران را به صفحات دلخواه خود از جمله صفحات فیشینگ هدایت کند. لازم به ذکر است که سواستفاده از این آسیب‌پذیری ساده تلقی شده و مدیران مربوطه می‌بایست هر چه سریعتر نسبت به وصله نمودن سرویس دهنده خود اقدام نمایند.

شکل 1 آسیب پذیری های Buffer overflow ذکر شده

شکل 2 آسیب پذیری های DNS Cache Poisoning ذکر شده

با توجه به بررسی های صورت گرفته تمامی نسخه های قبل از نسخه 2.83 آسیب پذیر می باشند. با اجرای دستور زیر در خط فرمان میتوان شماره نسخه سرویس دهنده خود را مشاهده نمود.

dnsmasq -v

به مدیران و مسئولان مربوطه تاکید می شود تا از آخرین نسخه موجود یعنی نسخه 2.83 استفاده و سرویس دهنده خود را هرچه سریع‌تر به‌روزرسانی نمایند. همچنین در صورت عدم نیاز به این سرویس دهنده آن را غیرفعال نموده یا تنظیمات را به گونه‌ای انجام دهند که این سرویس دهنده صرفا در شبکه داخلی اقدام به خدمت رسانی نماید.
با توجه به راه حل های اشاره شده در منابع مختلف برای جلوگیری از آسیب پذیری DNS cache poisoning نیاز است تا ویژگی DNSSEC فعال باشد اما در صورت فعال سازی این ویژگی مهاجم میتواند حملات Buffer overflow اشاره شده در متن گزارش را اجرا نماید به همین منظور راه حل های موقت برای مرتفع سازی این آسیب پذیری ها مورد تایید مرکز ماهر نیست.

منابع


مشخصات خبر

 
تاریخ ایجاد: 24 فروردین 1400

امتیاز

امتیاز شما
تعداد امتیازها: 0