فا

‫ اخبار

آسيب‌پذيری‌های Magellan 2.0 در گوگل کروم

محققان امنیتی اخیراً پنج #‫آسیب‌پذیری در مرورگر #‫گوگل کروم فاش کرده‌اند که می‌توانند توسط یک مهاجم برای اجرای کد از راه دور مورد سوءاستفاده قرار بگیرد.
این آسیب‌پذیری‌ها در سیستم مدیریت پایگاه‌داده‌ی SQLite وجود دارد. SQLite یک موتور پایگاه‌داده‌ی سبک است که به‌طور گسترده در مرورگرها، سیستم‌عامل‌ها و تلفن‌های همراه مورد استفاده قرار می‌گیرد.
این مجموعه که Magellan 2.0 نام دارد، از پنج آسیب‌پذیری (CVE-2019-13734، CVE-2019-13750،CVE-2019-13751 ،CVE-2019-13752 و CVE-2019-13753) تشکیل شده است. این آسیب‌پذیری‌ها می‌توانند از راه دور و از طریق صفحه‌ی HTML دستکاری‌شده مورد سوءاستفاده قرار گیرند تا مجموعه‌ای از حملات مخرب را انجام دهند.
آسیب‌پذیری‌های Magellan 2.0 به‌علت اعتبارسنجی ورودی نامناسب در دستورات SQL است که پایگاه‌داده‌ی SQLite از شخص ثالث دریافت می‌کند.
یک مهاجم می‌تواند عملیات SQL را ایجاد کند که حاوی عملیات مخرب است. هنگامی که موتورهای پایگاه‌داده‌ی SQLite این عملیات را بخواند، می‌تواند از طرف مهاجم دستورات را انجام دهد.
Magellan 2.0 بر روی نقص‌های Magellan که قبلاً فاش شده است، سه ضعف سرریز بافر و آسیب‌پذیری افشای داده‌های هیپ درSQLite (CVE-2018-20346 ، CVE-2018-20505، CVE-2018-20506) ایجاد می‌کند و منجر به اجرای کد از راه دور، نشت حافظه‌ی برنامه یا ایجاد خرابی برنامه می‌شود.
تمام برنامه‌هایی که از یک پایگاه‌داده‌ی SQLite استفاده می‌کنند، در برابر این مجموعه، آسیب‌پذیر هستند. این آسیب‌پذیری‌ها همچنین مرورگرهایی را که در آن‌ها WebSQL فعال است، تحت تأثیر قرار می‌دهند. دستگاه‌هایی که از نسخه‌های قدیمی Chrome و Chromium استفاده می‌کنند، برنامه‌های کاربردی که از نسخه‌های قدیمی Webview استفاده می‌کنند و می‌توانند به هر صفحه‌ای دسترسی داشته باشند نیز تحت تأثیر این آسیب‌پذیری‌ها قرار می‌گیرند.
راهکارها و وصله‌ها
این نقص در 16 نوامبر سال 2019 به گوگل و SQLite گزارش شد. در 11 دسامبر 2019، گوگل نسخه‌ی 79.0.3945.79 کروم را منتشر و این آسیب‌پذیری را وصله کرد.
SQLite نیز این اشکالات را در مجموعه‌ای از وصله‌ها برطرف کرده است.


مشخصات خبر

 
تاریخ ایجاد: 18 دی 1398

برچسب‌ها

امتیاز

امتیاز شما
تعداد امتیازها: 0