فا

‫ نقص جديد آپاچی و تأثير آن بر دو ميليون سرور HTTP

بنیاد نرم‌افزار #‫آپاچی، یک آسیب‌پذیری شدید در پروژه‌ی وب‌سرور آپاچی (httpd) وصله کرده است که به اسکریپت‌های سرکش سرور اجازه می‌دهد تا بتوانند کد را با امتیازات ریشه اجرا کنند و سرور پایه را در اختیار گیرند.
وب‌سرور آپاچی یکی از محبوب‌ترین و گسترده‌ترین وب‌سرورهای منبع‌باز در جهان است که تقریباً ۴۰ درصد از کل اینترنت را پشتیبانی می‌کند.
این آسیب‌پذیری که با شناسه‌ی "CVE-2019-0211" ردیابی می‌شود، نسخه‌های آپاچی HTTP Server را فقط در سیستم‌های یونیکس از 2.4.17 تا 2.4.38 تحت تأثیر قرار می‌دهد و با انتشار نسخه‌ی 2.4.39 رفع شده است.
به‌گفته‌ی کارشناسان امنیتی، بیش از 2 میلیون سرور آپاچی HTTP تحت تأثیر نقص تشدید امتیازات "CVE-2019-0211" قرار دارند.
این آسیب‌پذیری مهم افزایش امتیاز می‌تواند توسط کاربران مورد سوءاستفاده قرار گیرد تا حق نوشتن و اجرای اسکریپت‌ها را برای به‌دست آوردن ریشه در سیستم‌های یونیکس به‌دست آورند.
در Apache HTTP Server نسخه‌ی 2.4.17 تا 2.4.38، با رویداد MPM، worker یا prefork، می‌توان کد دلخواه را با امتیازات فرایند اصلی (معمولاً ریشه) و با دست‌کاری scoreboard اجرا کرد. سیستم‌های غیریونیکس تحت تأثیر این آسیب‌پذیری قرار نمی‌گیرند.
طبق گفته‌ی تیم آپاچی، پردازنده‌های فرزند (مانند اسکریپت هایCGI ) می‌توانند کد مخرب را با امتیازات فرآیند والدین اجرا کنند.
از آنجایی که در اکثر سیستم‌های یونیکس آپاچی، httpd تحت کاربر ریشه اجرا می‌شود، هر تهدیدکننده‌ای که یک اسکریپت CGI مخرب را بر روی یک سرور آپاچی نصب می‌کند، می‌تواند از "CVE-2019-0211" برای استفاده از سیستم پایه‌ای که در حال اجرای پروسس httpd پروتکل آپاچی است، استفاده کند و کنترل کل دستگاه را به‌‌دست گیرد.
این آسیب‌پذیری در HTTP سرور آپاچی یافت شده و وصله شده است؛ اما هنوز هم تعداد زیادی از سرورهای در حال اجرای نسخه‌های قدیمی‌تر و وصله‌نشده را تحت تأثیر قرار می‌دهد. صدها هزار وب‌سایت و سرور هنوز می‌توانند به‌طور بالقوه در معرض حملات سایبری قرار گیرند.
براساس تحلیلات انجام‌شده، بیش از دو میلیون سرور و بسیاری از سیستم‌عامل‌های ابر عمومی، هنوز نسخه‌های آسیب‌پذیر آپاچی را اجرا می‌کنند. بیشتر سیستم‌هایی که تحت تأثیر این آسیب‌پذیری قرار گرفته‌اند، در ایالات متحده (حدود 770،000)، آلمان (حدود 224،000) و فرانسه (حدود 111،000) هستند.
این آسیب‌پذیری ممکن است یک تهدید فوری و قابل لمس برای توسعه‌دهندگان و شرکت‌هایی که زیرساخت‌های سرور خود را اداره می‌کنند، ایجاد نکند؛ اما یک آسیب‌پذیری حیاتی در محیط میزبانی وب به‌حساب می‌آید.
سازمان‌ها باید در اسرع وقت وصله‌ی آپاچی را دریافت کنند و اگر سازمان‌ها، وب‌سایت خود را در یک میزبان وب که تحت تأثیر این مسئله قرار گرفته است، میزبانی می‌کنند، باید فوراً آن‌را وصله‌کنند یا به یک ارائه‌دهنده/پلت‌فرم دیگر انتقال دهند.


نظرات

بدون نظر
شما برای نظر دادن باید وارد شوید

مشخصات خبر

 
تاریخ ایجاد: 25 فروردین 1398

برچسب‌ها

امتیاز

امتیاز شما
تعداد امتیازها: 0