‫ هشدار WordPress در خصوص نسخه‌‌های تاریخ گذشته‌ی PHP

در دسامبر سال گذشته، #‫سیستم_مدیریت_محتوا(CMS) متن‌باز و رایگان اعلام کرد 85% از وب‌سایت‌هایی که WordPress 5.0 را اجرا می‌کنند، از PHP 5.0 یا بیشتر استفاده می‌کنند.
PHP 5.6 پایین‌ترین نسخه‌ی PHP است که سایت‌های WordPress به آن نیاز دارند و به مدیران سایتی که نسخه‌های تاریخ گذشته‌ی PHP را استفاده می‌کنند، هشدار داده می‌شود. این هشدار حاوی لینکی (در قالب یک دکمه) به یک صفحه جدید نیز است که دارای اطلاعات مربوط به چگونگی به‌روزرسانی PHP است.
WordPress هنوز هم به‌روزرسانی‌های امنیتی و رفع اشکالات را برای وب‌سایت‌هایی که می‌خواهند از نسخه‌ی PHP 5.5 یا پایین‌تر استفاده کنند، ارایه می‌دهد. البته این سایت‌ها نمی‌توانند بدون آنکه ابتدا به نسخه‌ی پشتیبانی‌شده‌ی PHP جابه‌جا شوند، به آخرین نسخه‌ی WordPress ارتقا یابند.
WordPress 5.1 که قرار است 21 فوریه منتشر شود، اولین فاز پروژه Health Check را نیز پیاده‌سازی می‌کند. هدف این پروژه، بهبود ثبات و عملکرد کل اکوسیستم WordPress است. CMS همچنین شامل مکانیزمی برای شناسایی خطای مهلک ناشی از به‌روزرسانی نسخه‌ی PHP خواهد بود و آن‌ها را در بخش‌های طراحی‌شده‌ی خاصی از WordPress از این خطاها نجات خواهد داد.
اگرچه فرایند به‌روزرسانی ساده است و پلاگین‌ها و تم‌ها محبوب معمولاً به خوبی حفظ می‌شوند، ممکن است برخی از افزونه‌ها هنوز با آخرین نسخه‌‌های PHP سازگار نباشند که این امر می‌تواند منجر به خراب‌شدن سایت WordPress پس از به‌روزرسانی شود.
WordPress زمانی که یک خطای مهلک رخ می‌دهد، پلاگین و تم سازگار با آن را تشخیص خواهد داد ‌و در حالی که اطلاعات مربوط به افزونه را در قسمت مدیریت ارایه می‌‌دهد، آن را متوقف می‌سازد. افزونه‌ها پس از رفع مشکل می‌توانند ادامه یابند.
در WordPress 5.1، اگر مدیران سعی در نصب پلاگین‌هایی داشته باشند که به نسخه‌ی PHP بالاتری نسبت به نسخه‌ی فعلی نیاز داشته باشد، به آن‌ها هشدار می‌دهد. علاوه‌براین، CMS دکمه را برای نصب آن پلاگین‌ها غیرفعال خواهد ساخت. در آینده، به‌روزسانی پلاگین محدود خواهد شد (تم‌ها را نیز تحت‌تأثیر قرار می‌دهد).
در حال حاضر WordPress قصد دارد اگر نسخه‌ی PHP، پایین‌تر از 5.6 باشد، به مدیران هشدار دهد؛ اما ممکن است این مسئله به زودی تغییر کند. پایین‌ترین نسخه‌ی PHP که هنوز به‌روزرسانی امنیتی دریافت می‌کند، نسخه‌ی 7.1 است و حداقل نسخه‌ی مورد نیاز PHP تا پایان سال جاری ممکن است به 7 برسد.


نظرات

بدون نظر
شما برای نظر دادن باید وارد شوید

مشخصات خبر

 
تاریخ ایجاد: 7 بهمن 1397

برچسب‌ها

امتیاز

امتیاز شما
تعداد امتیازها: 0